Vous êtes nouveau sur Developpez.com ? Créez votre compte ou connectez-vous afin de pouvoir participer !

Vous devez avoir un compte Developpez.com et être connecté pour pouvoir participer aux discussions.

Vous n'avez pas encore de compte Developpez.com ? Créez-en un en quelques instants, c'est entièrement gratuit !

Si vous disposez déjà d'un compte et qu'il est bien activé, connectez-vous à l'aide du formulaire ci-dessous.

Identifiez-vous
Identifiant
Mot de passe
Mot de passe oublié ?
Créer un compte

L'inscription est gratuite et ne vous prendra que quelques instants !

Je m'inscris !

Sortie de Qt 5.12.4
Avec une nouvelle version d'OpenSSL pour disposer du protocole TLS 1.3, plus sécurisé pour les connexions chiffrées

Le , par dourouc05

170PARTAGES

3  0 
Quatrième version corrective pour Qt 5.12. Celle-ci corrige deux cent cinquante défauts par rapport à Qt 5.12.3. Cependant, un changement vaut la peine d'être remarqué : l'intégration d'OpenSSL 1.1.1. Les versions précédentes de Qt 5.12 resteront bloquées à OpenSSL 1.0 à cause d'une incompatibilité binaire. Cette évolution pourrait causer une série de problèmes pour la mise à jour de la version de Qt, mais est nécessaire pour la sécurité : seul OpenSSL 1.1 propose une implémentation de TLS 1.3, la nouvelle version du protocole sécurisant TCP (cette nouvelle version améliore aussi la performance des fonctions cryptographiques, mais ce point n'aurait pas été suffisant pour inciter à un tel changement).

Qt 5.12 est toujours en phase de maintenance active, c'est-à-dire que tous les défauts remarqués sont corrigés, même s'ils pourraient représenter un danger lors de la mise à jour. Qt 5.9, au contraire, est en phase stricte : seuls les correctifs n'ayant aucun risque sur les applications lors d'une mise à jour sont appliqués.

Source : Qt 5.12.4 Released with support for OpenSSL 1.1.1

Télécharger Qt 5.12.4.

Une erreur dans cette actualité ? Signalez-le nous !

Avatar de aureyoboss
Membre à l'essai https://www.developpez.com
Le 17/06/2019 à 20:25
Bonjour,

Donc en version 5.12.3, pour que l'OpenSSL fonctionne (compilation pour Windows), il fallait ajouter les fichiers dans la racine du projet x32 :
- libeay32.dll ;
- ssleay32.dll ;
- openssl.exe.

Avec la nouvelles version 5.12.4, est-ce bien ces fichiers qu'il faut à la place des anciens ?
- libcrypto-1_1.dll ;
- libssl-1_1.dll ;
- openssl.exe.

Merci.
Bonne soirée.
0  0 
Avatar de dourouc05
Responsable Qt & Livres https://www.developpez.com
Le 18/06/2019 à 16:22
A priori, ces deux DLL devraient suffire (je ne vois pas pourquoi Qt aurait besoin du fichier exécutable).
0  0 

 
Responsable bénévole de la rubrique Qt : Thibaut Cuvelier -

Partenaire : Hébergement Web