Qt Creator 2.5.2 est sorti
Tant en open source qu'en commercial, marquant les différences entre les deux éditions

Le , par dourouc05, Responsable Qt
La version 2.5.2 de Qt Creator, dans sa version libre, ne contient qu'un seul patch, pour un bogue majeur touchant les utilisateurs sous Windows 7 (des fuites mémoire menant à des crashs réguliers sous certaines circonstances). Ceux qui utilisent le Qt SDK pour les mises à jour sont d'ailleurs toujours à la version 2.4.1.

De l'autre côté, la version disponible dans le Qt Commercial SDK de Digia fixe, quant à elle, trois bogues majeurs d'utilisabilité (le précédent, ainsi que deux pour OSX) et une série d'autres bogues importants, en plus d'une maintenance des cibles Linux embarqué et d'autres spécificités à la version commerciale.

On voit déjà une certaine séparation entre les deux versions (d'un côté, open source, libre, gratuite ; de l'autre, commerciale) de l'EDI Qt, la version commerciale proposant des corrections supplémentaires sur des fonctionnalités communes ; de même dans le SDK : la version libre n'est toujours pas passée sur Qt Creator 2.5 (je viens d'ailleurs de revérifier à l'instant la disponibilité des mises à jour).

Faut-il s'attendre à de plus en plus d'événements de ce genre, de version commerciale nettement avantagée sur la version open source pour des fonctionnalités de base, suite aux annonces de rachat de Qt par Digia ?

Sources : http://labs.qt.nokia.com/2012/08/09/...-5-2-released/ et http://195.197.180.217/en/Blogs/Qt-b...-252-released/.


Vous avez aimé cette actualité ? Alors partagez-la avec vos amis en cliquant sur les boutons ci-dessous :


 Poster une réponse

Avatar de Troudhyl Troudhyl - Membre expérimenté https://www.developpez.com
le 14/08/2012 à 23:57
C'est vrai que... J'ai pris le SDK justement en pensant faciliter les mises à jour et les avoir automatiquement le jour-même de la sortie d'une nouveauté mais apparemment ce n'est pas trop l'esprit. Qt 4.8.2 n'y est pas encore non plus. Dommage...
Avatar de herr_wann herr_wann - Membre régulier https://www.developpez.com
le 15/08/2012 à 10:53
Je pense que c'est plus un problème lié au transfert des ingénieurs de Nokia à Digia ou des formalités juridiques, ce serait suicidaire de la part de Digia de ne pas mettre à jour des bugs sur la version open source. La différence, s'il doit y en avoir une, devrait être sur des fonctionnalités avancées.
Avatar de Gugelhupf Gugelhupf - Modérateur https://www.developpez.com
le 15/08/2012 à 11:32
C'est bizarre mais :


Ça ne devrait pas plutôt être :
Code : Sélectionner tout
1
2
3
for(const QString &elem : list) { 
    // ... 
}
?
Avatar de dourouc05 dourouc05 - Responsable Qt https://www.developpez.com
le 15/08/2012 à 11:33
Tout le monde n'a pas la chance d'avoir un compilateur qui supporte parfaitement C++11 (d'ailleurs, la construction Qt était disponible bien avant le standard ).
Avatar de xwz xwz - Membre du Club https://www.developpez.com
le 15/08/2012 à 14:59
Citation Envoyé par Gugelhupf  Voir le message
C'est bizarre mais :


Ça ne devrait pas plutôt être :
Code : Sélectionner tout
1
2
3
for(const QString &elem : list) { 
    // ... 
}
?

Il me semble que dans ce contexte c'est la macro foreach définit par Qt qui est utilisée.
Avatar de NeuhNeuh NeuhNeuh - Futur Membre du Club https://www.developpez.com
le 16/08/2012 à 1:00
Bonjour !

QtCreator est disponible en Version 2.5.1-78.2 (sur les dépôts de KDE 4.9 sous openSUSE) http://wstaw.org/m/2012/08/16/plasma-desktopwV1822.png

Je pense que la version 2.5.2 n'est soit :
→ Pas dans mes dépôts
→ Pas encore disponible
A bientôt !
Avatar de zelegolas2 zelegolas2 - Membre habitué https://www.developpez.com
le 16/08/2012 à 20:28
Citation Envoyé par NeuhNeuh  Voir le message
Bonjour !

QtCreator est disponible en Version 2.5.1-78.2 (sur les dépôts de KDE 4.9 sous openSUSE) http://wstaw.org/m/2012/08/16/plasma-desktopwV1822.png

Je pense que la version 2.5.2 n'est soit :
→ Pas dans mes dépôts
→ Pas encore disponible
A bientôt !

Je suis intéressé
J'ai intstallé OpenSUSE mais je connais pas bien cette distribution.
Peux tu m'indiquer qu'est ce que je dois faire pour installer KDE 4.9 et QtCreator 2.5.1 ?
Avatar de Linunix Linunix - Membre confirmé https://www.developpez.com
le 17/08/2012 à 15:18
Enfin, cette version sort
Offres d'emploi IT
Développeur Web FULL-STACK
VACALIANS GROUP - Languedoc Roussillon - SETE (34)
RESPONSABLE WEB ANALYTICS F/H
VACALIANS GROUP - Languedoc Roussillon - SETE (34)
Développeur WEB PHP F/H
VACALIANS GROUP - Languedoc Roussillon - SETE (34)

Voir plus d'offres Voir la carte des offres IT
Responsable bénévole de la rubrique Qt : Thibaut Cuvelier -